Choosing CUDA versions
CUDA 9 || CUDA 10 || CUDA 11. We have it here
For every TensorFlow version, ensure one has a compatible CUDA version. We support TensorFlow till 2.4.1 for now.
If you're on NimbleBox, one can choose between CUDA versions.
When you reset your environment from the dashboard, TensorFlow 2.4.1 is automatically installed (irrespective of the CUDA version selected). Please refer the below table to understand which TensorFlow version to install.

Steps :

    1.
    Go to dashboard
    2.
    Click on 'Start Project'
    3.
    Go to Jupyter Lab/Notebook
    4.
    Click on 'New'
    5.
    Select any of these options from the drop down
      Python 3
      ML and DL with CUDA 10.1
      ML and DL (Pytorch only) with CUDA 10.1
Alternatively, if you are already working on Jupyter:
    1.
    Go to 'Kernel'
    2.
    Change Kernel
    3.
    Select any of these options from the drop down
      Python 3
      ML and DL with CUDA 10.1
      ML and DL (Pytorch only) with CUDA 10.1
The following are the TensorFlow versions that are compatible with their respective CUDA versions
Change the CUDA version on NimbleBox
​
Last modified 1mo ago
Copy link